ElementCascadingDeleter Class
Deletes an entire element tree, including sub-models, child elements and code scope references. Items are deleted in bottom-up order. Definitions and Subjects are deleted after normal elements. Call deleteNormalElements on each tree. Then call deleteSpecialElements.
Extends
Methods
Name | Description | |
---|---|---|
processElementTree(element: string, scope: ElementTreeWalkerScope): void Protected | The main tree-walking function | |
shouldVisitCodeScopes(_elementId: string, _scope: ElementTreeWalkerScope): boolean Protected |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.