addCustomAspectChange Method
This method should only be called inside [IModelTransformer.addCustomChanges]. Adds the provided change to the aspect changes maintained by this instance of ChangedInstanceIds If the same ECInstanceId is seen multiple times, the changedInstanceIds will be modified accordingly, i.e. if an id 'x' was updated but now we see 'x' was deleted, we will remove 'x' from the set of updatedIds and add it to the set of deletedIds for the appropriate class type.
addCustomAspectChange(changeType: SqliteChangeOp, ids: Id64Arg): void
@note It is the responsibility of the caller to ensure that the provided id is, in fact an aspect.
@note In most cases, this method does not need to be called. Its only for consumers to mimic changes as if they were found in a changeset, which should only be useful in certain cases such as the changing of filter criteria for a preexisting master branch relationship.
Parameter | Type | Description |
---|---|---|
changeType | SqliteChangeOp | |
ids | Id64Arg |
Returns - void
Defined in
Last Updated: 06 March, 2025