addChange Method
Adds the provided ChangedECInstance to the appropriate set of changes by class type (codeSpec, model, element, aspect, or relationship) maintained by this instance of ChangedInstanceIds. If the same ECInstanceId is seen multiple times, the changedInstanceIds will be modified accordingly, i.e. if an id 'x' was updated but now we see 'x' was deleted, we will remove 'x' from the set of updatedIds and add it to the set of deletedIds for the appropriate class type.
addChange(change: ChangedECInstance): Promise<void>
Parameter | Type | Description |
---|---|---|
change | ChangedECInstance | ChangedECInstance which has the ECInstanceId, changeType (insert, update, delete) and ECClassId of the changed entity |
Returns - Promise
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.