ViewportProps Interface
Properties for ViewportComponent component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
imodel | IModelConnection | IModel to display | |
viewDefinitionId | string | undefined | Id of a default view definition to load as a starting point | |
viewState | ViewStateProp | undefined | ViewState to use as a starting point | |
viewportRef | (v: ScreenViewport) => void | undefined | Function to get a reference to the ScreenViewport |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.