QuantityProps Interface
Props for QuantityInput control
Extends
Properties
Name | Type | Description | |
---|---|---|---|
initialValue | number | Initial magnitude in 'persistence' units. | |
onQuantityChange | (newQuantityValue: number) => void | Function to call in the quantity value is changed. | |
quantityType | QuantityTypeArg | Type of quantity being input. | |
readonly | boolean | undefined | Set to true if value is for display only |
|
ref | React.Ref<HTMLInputElement> | undefined | Provides ability to return reference to HTMLInputElement |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.