ToolUtilities.isWithIcon Function

Type guard for a ($@itwin/core-frontend#ToolType$refLinkSource=imodel-components-react/ui/imodel-components-react/src/imodel-components-react/ToolUtilities.ts@45) with an iconElement property.

isWithIcon<T extends >(toolType: T): toolType is ToolWithIcon<T>

Parameter Type Description
toolType T  

Returns - toolType is ToolWithIcon<T>

Defined in

Last Updated: 17 December, 2024