ColorSwatchProps Interface
Deprecated in 4.11.0. Props of deprecated component ColorSwatch.
Properties for the ColorSwatch React component
Extends
- React.ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
colorDef | ColorDef | color specification | |
onColorPick | (color: ColorDef, e: React.MouseEvent<Element, MouseEvent>) => void | undefined | function to run when user selects color swatch | |
round | boolean | undefined | Show swatches as squares unless round is set to true |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.