ColorPickerProps Interface
Deprecated in 4.11.0. Props of deprecated component ColorPickerButton.
Properties for the ColorPickerButton React component
Extends
- React.ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
colorDefs | ColorDef[] | undefined | Available colors | |
disabled | boolean | undefined | Disabled or not | |
dropDownTitle | string | undefined | Title to show at top of DropDown | |
initialColor | ColorDef | Active color | |
numColumns | number | undefined | Number of columns | |
onColorPick | (color: ColorDef) => void | undefined | Function to run when user selects color swatch | |
readonly | boolean | undefined | Readonly or not | |
ref | React.Ref<HTMLButtonElement> | undefined | Provides ability to return reference to HTMLButtonElement | |
round | boolean | undefined | Show swatches as squares unless round is set to true | |
showCaret | boolean | undefined | If true show up/down caret next to color |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.