ColorPickerPopupProps Interface
Deprecated in 4.11.0. Props of deprecated component ColorPickerPopup.
Properties for the ColorPickerPopup React component
Extends
- React.ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
captureClicks | boolean | undefined | If true, don't propagate clicks out of the ColorPicker | |
colorDefs | ColorDef[] | undefined | Preset colors. | |
colorInputType | "hsl" | "rgb" | "hex" | If set show input values | |
disabled | boolean | undefined | Disabled or not | |
hideCloseButton | boolean | undefined | If true, don't show close button at top | |
initialColor | ColorDef | Current color | |
onClose | (colorValue: ColorDef) => void | undefined | Function to call when the popup is closed | |
onColorChange | (newColor: ColorDef) => void | undefined | Function to call when the color value is changed | |
popupPosition | RelativePosition | undefined | popup position. | |
readonly | boolean | undefined | Readonly or not, color displayed on button but button will not trigger pop-up | |
ref | React.Ref<HTMLButtonElement> | undefined | Provides ability to return reference to HTMLButtonElement | |
showCaret | boolean | undefined | If true show up/down caret next to color |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.