run Method

Run this instance of a Tool. Subclasses should override to perform some action.

run(idToQuery?: string, copyToClipboard?: boolean): Promise<boolean>

@returns true if the tool executed successfully.

Parameter Type Description
idToQuery string  
copyToClipboard boolean  

Returns - Promise

true if the tool executed successfully.

Defined in

Last Updated: 14 November, 2024