run Method

Run this instance of a Tool. Subclasses should override to perform some action.

run(vf: ViewFlags, vp?: Viewport): Promise<boolean>

@returns true if the tool executed successfully.

Parameter Type Description
vf ViewFlags  
vp Viewport  

Returns - Promise

true if the tool executed successfully.

Defined in

Last Updated: 14 November, 2024