SchemaItemOverrideFormatProps Interface
Extends
Properties
Name | Type | Description | |
---|---|---|---|
parent Readonly | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
$schema Readonly Inherited | string | undefined | SchemaItemFormatProps | |
allowMathematicOperations Readonly Inherited | boolean | undefined | SchemaItemFormatProps | |
azimuthBase Readonly Inherited | number | undefined | SchemaItemFormatProps | The base value for azimuth, specified from east counter-clockwise. |
azimuthBaseUnit Readonly Inherited | string | undefined | SchemaItemFormatProps | The name of the unit for the azimuth base value. |
azimuthCounterClockwise Readonly Inherited | boolean | undefined | SchemaItemFormatProps | If set to true, azimuth values are returned counter-clockwise from the base. |
composite Readonly Inherited | { includeZero?: boolean, spacer?: string, units: { label?: string, name: string }[] } | undefined | SchemaItemFormatProps | |
customAttributes Readonly Inherited | { T }[] | undefined | SchemaItemFormatProps | |
decimalSeparator Readonly Inherited | string | undefined | SchemaItemFormatProps | |
description Readonly Inherited | string | undefined | SchemaItemFormatProps | |
formatTraits Readonly Inherited | string | string[] | SchemaItemFormatProps | |
label Readonly Inherited | string | undefined | SchemaItemFormatProps | |
minWidth Readonly Inherited | number | undefined | SchemaItemFormatProps | |
name Readonly Inherited | string | undefined | SchemaItemFormatProps | |
originalECSpecMajorVersion Readonly Inherited | number | undefined | SchemaItemFormatProps | |
originalECSpecMinorVersion Readonly Inherited | number | undefined | SchemaItemFormatProps | |
precision Readonly Inherited | number | undefined | SchemaItemFormatProps | |
ratioType Readonly Inherited | string | undefined | SchemaItemFormatProps | conditionally required. |
revolutionUnit Readonly Inherited | string | undefined | SchemaItemFormatProps | The name of the unit that represents a revolution/perigon. |
roundFactor Readonly Inherited | number | undefined | SchemaItemFormatProps | |
schema Readonly Inherited | string | undefined | SchemaItemFormatProps | |
schemaItemType Readonly Inherited | string | undefined | SchemaItemFormatProps | |
schemaVersion Readonly Inherited | string | undefined | SchemaItemFormatProps | |
scientificType Readonly Inherited | string | undefined | SchemaItemFormatProps | conditionally required. |
showSignOption Readonly Inherited | string | undefined | SchemaItemFormatProps | |
stationOffsetSize Readonly Inherited | number | undefined | SchemaItemFormatProps | conditionally required. |
stationSeparator Readonly Inherited | string | undefined | SchemaItemFormatProps | |
thousandSeparator Readonly Inherited | string | undefined | SchemaItemFormatProps | |
type Readonly Inherited | string | SchemaItemFormatProps | |
uomSeparator Readonly Inherited | string | undefined | SchemaItemFormatProps |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.