classCompatibleWithConstraint MethodStatic
Indicates if an ECClass is of the type or applies to the type (if a mixin) of the ECClass specified by the constraintClass parameter.
classCompatibleWithConstraint(constraintClass: ECClass, testClass: ECClass, isPolymorphic: boolean): Promise<boolean>
Parameter | Type | Description |
---|---|---|
constraintClass | ECClass | The ECClass that is a constraint class of a relationship. |
testClass | ECClass | The ECClass to check against the constraint class. |
isPolymorphic | boolean | Indicates if the testClass should be checked polymorphically. |
Returns - Promise
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.