EnumerationProps Interface

Extends

Properties

Name Type Description
enumerators Readonly EnumeratorProps[]    
isStrict Readonly boolean    
type Readonly string    

Inherited properties

Name Type Inherited from Description
$schema Readonly Inherited string | undefined SchemaItemProps  
customAttributes Readonly Inherited { T }[] | undefined SchemaItemProps  
description Readonly Inherited string | undefined SchemaItemProps  
label Readonly Inherited string | undefined SchemaItemProps  
name Readonly Inherited string | undefined SchemaItemProps  
originalECSpecMajorVersion Readonly Inherited number | undefined SchemaItemProps  
originalECSpecMinorVersion Readonly Inherited number | undefined SchemaItemProps  
schema Readonly Inherited string | undefined SchemaItemProps  
schemaItemType Readonly Inherited string | undefined SchemaItemProps  
schemaVersion Readonly Inherited string | undefined SchemaItemProps  

Defined in

Last Updated: 14 November, 2024