createEnumerator Method

Creates an Enumerator with the provided name and value as well as optional parameters label and description

createEnumerator(name: string, value: string | number, label?: string, description?: string): AnyEnumerator

@returns AnyEnumerator object

Parameter Type Description
name string The name of the enumerator
value string | number The value of the enumerator. The type of this value is dependent on the backing type of the this Enumeration.
label string A localized display label that is used instead of the name in a GUI.
description string A localized description for the enumerator.

Returns - AnyEnumerator

AnyEnumerator object

Defined in

Last Updated: 14 November, 2024