EntityClassProps Interface

Extends

Properties

Name Type Description
mixins Readonly string[] | undefined    

Inherited properties

Name Type Inherited from Description
$schema Readonly Inherited string | undefined ClassProps  
baseClass Readonly Inherited string | undefined ClassProps  
customAttributes Readonly Inherited { T }[] | undefined ClassProps  
description Readonly Inherited string | undefined ClassProps  
label Readonly Inherited string | undefined ClassProps  
modifier Readonly Inherited string | undefined ClassProps  
name Readonly Inherited string | undefined ClassProps  
originalECSpecMajorVersion Readonly Inherited number | undefined ClassProps  
originalECSpecMinorVersion Readonly Inherited number | undefined ClassProps  
properties Readonly Inherited AnyPropertyProps[] | undefined ClassProps  
schema Readonly Inherited string | undefined ClassProps  
schemaItemType Readonly Inherited string | undefined ClassProps  
schemaVersion Readonly Inherited string | undefined ClassProps  

Defined in

Last Updated: 14 November, 2024