encode MethodStatic
Create an ECName from an arbitrary string, encoding any special characters as "x####" where "####" is the UTF-16 character code.
encode(input: string): ECName
@throws ECObjectsError if input
is an empty string.
Parameter | Type | Description |
---|---|---|
input | string |
Returns - ECName
Defined in
- ecschema-metadata/src/ECName.ts Line 62
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.