traverseBaseClasses Method
Asynchronously traverses through the inheritance tree, using depth-first traversal, calling the given callback function for each base class encountered.
traverseBaseClasses(callback: (ecClass: ECClass, arg?: any) => boolean, arg?: any): Promise<boolean>
Parameter | Type | Description |
---|---|---|
callback | (ecClass: ECClass, arg?: any) => boolean | The function to call for each base class in the hierarchy. |
arg | any | An argument that will be passed as the second parameter to the callback function. |
Returns - Promise
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.