CustomAttributeClassProps Interface
Extends
Properties
Name | Type | Description | |
---|---|---|---|
appliesTo Readonly | string | Can be any combination of the [CustomAttributeContainerType]$(docs/bis/ec/customattribute-container-types.md) string values |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
$schema Readonly Inherited | string | undefined | ClassProps | |
baseClass Readonly Inherited | string | undefined | ClassProps | |
customAttributes Readonly Inherited | { T }[] | undefined | ClassProps | |
description Readonly Inherited | string | undefined | ClassProps | |
label Readonly Inherited | string | undefined | ClassProps | |
modifier Readonly Inherited | string | undefined | ClassProps | |
name Readonly Inherited | string | undefined | ClassProps | |
originalECSpecMajorVersion Readonly Inherited | number | undefined | ClassProps | |
originalECSpecMinorVersion Readonly Inherited | number | undefined | ClassProps | |
properties Readonly Inherited | AnyPropertyProps[] | undefined | ClassProps | |
schema Readonly Inherited | string | undefined | ClassProps | |
schemaItemType Readonly Inherited | string | undefined | ClassProps | |
schemaVersion Readonly Inherited | string | undefined | ClassProps |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.