getSchemaItem Method
Gets the schema item from the specified schema if it exists in this SchemaContext. Will await a partially loaded schema then look in it for the requested item
getSchemaItem<T extends SchemaItem>(schemaItemKey: SchemaItemKey): Promise<undefined | T>
@returns The requested schema item
Parameter | Type | Description |
---|---|---|
schemaItemKey | SchemaItemKey | The SchemaItemKey identifying the item to return. SchemaMatchType.Latest is used to match the schema. |
Returns - Promise<undefined | T>
The requested schema item
Defined in
- ecschema-metadata/src/Context.ts Line 391
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.