getSchemaSync Method
Attempts to get a schema from the locater. Yields undefined if no matching schema is found. For schemas that may have references, construct and call through a SchemaContext instead.
getSchemaSync<T extends Schema>(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchType, context: SchemaContext): undefined | T
Parameter | Type | Description |
---|---|---|
schemaKey | Readonly<SchemaKey> | key to look up |
matchType | SchemaMatchType | how to match key against candidate schemas |
context | SchemaContext | context for loading schema references |
Returns - undefined | T
Defined in
- ecschema-metadata/src/Context.ts Line 61
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.