getSchema Method
Attempts to retrieve a Schema with the given SchemaKey by searching the configured Schema strings.
getSchema<T extends Schema>(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | T>
Parameter | Type | Description |
---|---|---|
schemaKey | SchemaKey | |
matchType | SchemaMatchType | The SchemaMatchType. |
context | SchemaContext | The SchemaContext that will control the lifetime of the schema and holds the schema's references, if they exist. |
Returns - Promise<undefined | T>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.