getSchema Method

Attempts to retrieve a Schema with the given SchemaKey by using the configured search paths to locate the XML Schema file from the file system.

getSchema<T extends Schema>(key: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | T>

Parameter Type Description
key SchemaKey The SchemaKey of the Schema to retrieve.
matchType SchemaMatchType The SchemaMatchType.
context SchemaContext The SchemaContext that will control the lifetime of the schema.

Returns - Promise<undefined | T>

Defined in

Last Updated: 14 November, 2024