getSchemaInfo Method
Gets the schema info which matches the provided SchemaKey. The schema info may be returned before the schema is fully loaded. The fully loaded schema can be gotten later from the context using the getCachedSchema method.
getSchemaInfo(schemaKey: SchemaKey, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | SchemaInfo>
Parameter | Type | Description |
---|---|---|
schemaKey | SchemaKey | The SchemaKey describing the schema to get from the cache. |
matchType | SchemaMatchType | The match type to use when locating the schema |
context | SchemaContext | The SchemaContext that will control the lifetime of the schema and holds the schema's references, if they exist. |
Returns - Promise<undefined | SchemaInfo>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.