constructor Method
Initializes a new PropertyDiagnostic.
PropertyDiagnostic<ARGS extends any[]>(property: AnyProperty, messageArgs?: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): PropertyDiagnostic<ARGS>
Parameter | Type | Description |
---|---|---|
property | AnyProperty | The property to associate with the diagnostic. |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - PropertyDiagnostic<ARGS>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.