getIconClassName MethodStatic

Overloads
getIconClassName(severity) Static  
getIconClassName(severity, hollow?) Static Deprecated  

getIconClassName(severity)

Returns the class name corresponding to the MessageSeverity.

getIconClassName(severity: MessageSeverity): string

Parameter Type Description
severity MessageSeverity MessageSeverity

Returns - string



getIconClassName(severity, hollow?)

Deprecated  in 4.0.0. Hollow parameter ignored, WebFont is not returned, only the color.

Returns the class name associated with the WebFont icon corresponding to the MessageSeverity.

getIconClassName(severity: MessageSeverity, hollow?: boolean): string

Parameter Type Description
severity MessageSeverity MessageSeverity
hollow boolean Should the icon be hollow

Returns - string


Defined in

Last Updated: 14 November, 2024