createArrowMarker Method
Get an existing or create a new reusable symbol representing an arrow head. If a Marker for the supplied color and size already exists it is returned, otherwise a new Marker is created.
createArrowMarker(color: string, length: number, width: number): @svgdotjs/svg.js.Marker
@note Flashing doesn't currently affect markers, need support for "context-stroke" and "context-fill". For now encode color in name...
Parameter | Type | Description |
---|---|---|
color | string | the arrow head color |
length | number | the arrow head length |
width | number | the arrow head width |
Returns - @svgdotjs/svg.js.Marker
Defined in
- markup/src/Markup.ts Line 509
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.