initialize Method
This method must be called and awaited before using an instance of Localization.
initialize(namespaces: string[]): Promise<void>
@note IModelApp.startup calls this internally, so you should not call this method directly except for Localization instances outside of IModelApp (e.g., for tests.)
Parameter | Type | Description |
---|---|---|
namespaces | string[] | an array of namespaces to load. There must be at least one namespace, and it becomes the default namespace. |
Returns - Promise
Defined in
- ITwinLocalization.ts Line 71
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.