isMaskConsistentAroundAllFaces MethodStatic
Test if a mask is used consistently around faces.
- At the low level, there is no actual traversal around faces. It is only necessary to verify that the mask matches for each HalfEdge and its faceSuccessor.
isMaskConsistentAroundAllFaces(graph: , mask: ): boolean
@returns Return true if mask is "all or nothing around all faces"
Parameter | Type | Description |
---|---|---|
graph | ||
mask |
Returns - boolean
Return true if mask is "all or nothing around all faces"
Defined in
- topology/HalfEdgeGraphValidation.ts Line 111
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.