createAlongArc MethodStatic
Create a TorusPipe from major arc and minor radius.
For best results, arc
should be circular; otherwise, circularity is coerced.
createAlongArc(arc: Arc3d, minorRadius: number, capped: boolean): undefined | TorusPipe
Parameter | Type | Description |
---|---|---|
arc | Arc3d | |
minorRadius | number | |
capped | boolean |
Returns - undefined | TorusPipe
Defined in
- solid/TorusPipe.ts Line 140
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.