sweepToUnionOfConvexClipPlaneSets Method

Create a UnionOfConvexClipPlaneSets that clips to the swept faceted contour region.

sweepToUnionOfConvexClipPlaneSets(sweepVector?: Vector3d, cap0: booleanfalse, cap1: booleanfalse, options?: StrokeOptions): undefined | UnionOfConvexClipPlaneSets

@returns clipper defined by faceting then sweeping the contour region

Parameter Type Description
sweepVector Vector3d the sweep direction and distance:
* If undefined, the sweep direction is along the contour normal and no caps are constructed (the sweep is infinite in both directions).
* If defined, the returned clipper is inverted if and only if sweepVector is in the opposite half-space as the computed contour normal.
cap0 boolean construct a clip plane equal to the contour plane. Note that sweepVector must be defined.
cap1 boolean construct a clip plane parallel to the contour plane at the end of sweepVector.
options StrokeOptions how to stroke the contour

Returns - undefined | UnionOfConvexClipPlaneSets

clipper defined by faceting then sweeping the contour region

Defined in

Last Updated: 13 November, 2024