createForPolygon MethodStatic
Create for linear sweep.
createForPolygon(points: MultiLineStringDataVariant, defaultNormal?: Vector3d): undefined | SweepContour
Parameter | Type | Description |
---|---|---|
points | MultiLineStringDataVariant | polygon to sweep, CAPTURED as a Loop. Closure point is optional. If multiple polygons are passed in, parity logic is employed. For best results, all points should be coplanar. |
defaultNormal | Vector3d | optional default normal for guiding coordinate frame setup. |
Returns - undefined | SweepContour
Defined in
- solid/SweepContour.ts Line 76
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.