buildFacets Method
Build the (cached) internal facets for the contour.
buildFacets(options?: StrokeOptions): void
Parameter | Type | Description |
---|---|---|
options | StrokeOptions | primarily how to stroke the contour, but also how to facet it. * By default, a triangulation is computed, but if options.maximizeConvexFacets === true , edges between coplanar triangles are removed to return maximally convex facets. |
Returns - void
Defined in
- solid/SweepContour.ts Line 174
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.