mutatePartners MethodStatic
Construct a CurveCollection with the same structure as collectionA and collectionB, with primitives constructed by the caller-supplied primitiveMutator function.
mutatePartners(collectionA: CurveCollection, collectionB: CurveCollection, primitiveMutator: CurvePrimitiveMutator): undefined | CurveCollection
@returns Returns undefined if there is any type mismatch between the two collections.
Parameter | Type | Description |
---|---|---|
collectionA | CurveCollection | |
collectionB | CurveCollection | |
primitiveMutator | CurvePrimitiveMutator |
Returns - undefined | CurveCollection
Returns undefined if there is any type mismatch between the two collections.
Defined in
- solid/RuledSweep.ts Line 158
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.