createZSweep MethodStatic
Create a z-direction sweep of the polyline or polygon given as xy linestring values.
- If not capped, the xyPoints array is always used unchanged.
- If capped but the xyPoints array does not close, exact closure will be enforced by one of these:
- If the final point is almost equal to the first, it is replaced by the exact first point.
- if the final point is not close to the first an extra point is added.
- If capped, the point order will be reversed if necessary to produce positive volume.
createZSweep(xyPoints: Readonly<WritableXAndY>[], z: number, zSweep: number, capped: boolean): undefined | LinearSweep
Parameter | Type | Description |
---|---|---|
xyPoints | Readonly<WritableXAndY>[] | array of xy coordinates |
z | number | z value to be used for all coordinates |
zSweep | number | the sweep distance in the z direction. |
capped | boolean | true if caps are to be added. |
Returns - undefined | LinearSweep
Defined in
- solid/LinearSweep.ts Line 67
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.