strokeConstantVSection Method
return strokes for a cross-section (elliptic arc) at specified fraction v along the axis.
- fixedStrokeCount takes priority over stroke options.
- The linestring is created by LineString3d.createForStrokes (fixedStrokeCount, options), which sets up property according to the options:
- optional fractions member
- optional uvParams. uvParams are installed as full-scale distance parameters.
- optional derivatives.
strokeConstantVSection(v: number, fixedStrokeCount: number, options: StrokeOptions): LineString3d
Parameter | Type | Description |
---|---|---|
v | number | fractional position along the cone axis |
fixedStrokeCount | number | optional stroke count. |
options | StrokeOptions | optional stroke options. |
Returns - LineString3d
Defined in
- solid/Cone.ts Line 154
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.