createBaseAndTarget MethodStatic
create a cylinder or cone from axis start and end with cross section defined by vectors that do not need to be perpendicular to each other or to the axis.
createBaseAndTarget(centerA: Point3d, centerB: Point3d, vectorX: Vector3d, vectorY: Vector3d, radiusA: number, radiusB: number, capped: boolean): Cone
Parameter | Type | Description |
---|---|---|
centerA | Point3d | |
centerB | Point3d | |
vectorX | Vector3d | |
vectorY | Vector3d | |
radiusA | number | |
radiusB | number | |
capped | boolean |
Returns - Cone
Defined in
- solid/Cone.ts Line 103
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.