prepareBSplineCurveData MethodStatic

Prepare data from a B-spline curve for export.

  • adds classic extraneous knot at start and end of knot vector
  • re-closes periodic data based on BSplineWrapMode

prepareBSplineCurveData(data: SerializationHelpers.BSplineCurveData, options?: SerializationHelpers.BSplineDataOptions): boolean

@returns whether data was successfully prepared

Parameter Type Description
data SerializationHelpers.BSplineCurveData updated in place. If poles/weights/knots are updated, their respective arrays are reallocated.
options SerializationHelpers.BSplineDataOptions output specifications

Returns - boolean

whether data was successfully prepared

Defined in

Last Updated: 14 November, 2024