SerializationHelpers.announceZeroBasedIndicesWithExternalBlocking Function
Process 0-based indices with blocking specified by another index array.
announceZeroBasedIndicesWithExternalBlocking(sourceIndices: Int32Array, blockingIndices: Int32Array, numPerBlock: number, announceZeroBasedIndex: (i0: number) => any, terminateBlock?: () => any): void
Parameter |
Type |
Description |
sourceIndices |
Int32Array |
0-based source indices. This array is compressed (has no blocking). |
blockingIndices |
Int32Array |
1-based source indices, blocking specified by numPerBlock . Assumed to have length equal to its zero count plus sourceIndices.length . |
numPerBlock |
number |
index blocking: fixed blocks of size numPerBlock > 1, possibly 0-padded; otherwise, variable-sized blocks terminated by 0 |
announceZeroBasedIndex |
(i0: number) => any |
callback to receive a 0-based index |
terminateBlock |
() => any |
optional callback called after each index block has been announced |
Returns - void
Defined in
Last Updated: 14 November, 2024