createUniformKnots MethodStatic
Create a homogeneous B-spline curve with uniform knots.
- Control points may be supplied as:
- array of Point4d, with weight already multiplied into the
[wx,wy,wz,w]
- array of Point3d, with implied weight 1.
- Float64Array, blocked as [wx,wy,wz,w], i.e. 4 numbers per control point.
- array of Point4d, with weight already multiplied into the
createUniformKnots(controlPoints: Float64Array | Point3d[] | Point4d[], order: number): undefined | BSplineCurve3dH
Parameter | Type | Description |
---|---|---|
controlPoints | Float64Array | Point3d[] | Point4d[] | pole data in array form as noted above. |
order | number | curve order (1 more than degree) |
Returns - undefined | BSplineCurve3dH
Defined in
- bspline/BSplineCurve3dH.ts Line 112
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.