create MethodStatic
Create a bspline with given knots.
- The poles have several variants:
- Float64Array(4 * numPoles) in blocks of [wx,xy,wz,w]
- Point4d[numPoles]
- Point3d[], with implied unit weight to be added
- number[][], with inner dimension 4
- {xyz: Float64Array(3 * numPoles), weights: Float64Array (numPoles)}
- Two count conditions are recognized:
- If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order == knotArray.length + 2, the knots are in modern form.
create(controlPointData: Float64Array | number[][] | Point3d[] | Point4d[] | { weights: Float64Array, xyz: Float64Array }, knotArray: Float64Array | number[], order: number): undefined | BSplineCurve3dH
Parameter | Type | Description |
---|---|---|
controlPointData | Float64Array | number[][] | Point3d[] | Point4d[] | { weights: Float64Array, xyz: Float64Array } | |
knotArray | Float64Array | number[] | |
order | number |
Returns - undefined | BSplineCurve3dH
Defined in
- bspline/BSplineCurve3dH.ts Line 282
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.