createPeriodicUniformKnots MethodStatic

Create a smoothly closed homogeneous B-spline curve with uniform knots.

  • Note that the curve does not start at the first pole!
  • Control points (poles) may be supplied as:
    • array of Point4d, with weight already multiplied into the [wx,wy,wz,w]
    • array of Point3d, with implied weight 1.
    • Float64Array, blocked as [wx,wy,wz,w], i.e. 4 numbers per control point.

createPeriodicUniformKnots(poles: Float64Array | Point3d[] | Point4d[], order: number): undefined | BSplineCurve3dH

Parameter Type Description
poles Float64Array | Point3d[] | Point4d[] control point data in array form as noted above.
order number curve order (1 more than degree)

Returns - undefined | BSplineCurve3dH

Defined in

Last Updated: 28 October, 2024