edgeHasLargeExteriorAngleBetweenNormals MethodStatic
Compute the angle between plane normals on opposite sides of the edge.
- parallel normals have zero angle.
- if the edge cuts inward to the volume behind the faces, the angle is negative.
- if the edge is outward (a convex edge) the the volume, the angle is positive.
edgeHasLargeExteriorAngleBetweenNormals(edgeNodeA: , edgeVector: Vector3d, averageNormal: Vector3d, offsetDistance: number, radiansTolerance: number...): boolean
@returns true if this edge has SectorOffsetProperties on both sides and the angle between normals angle exceeds radiansTolerance.
Parameter | Type | Description |
---|---|---|
edgeNodeA | node on one side of the edge | |
edgeVector | Vector3d | pre-allocated vector to receive vector along edge. |
averageNormal | Vector3d | pre-allocated vector to receive the average normal for a chamfer of the offset edge. |
offsetDistance | number | distance of offset being constructed. The sign of this resolves angle ambiguity. |
radiansTolerance | number | tolerance for large angle between normals. |
Returns - boolean
true if this edge has SectorOffsetProperties on both sides and the angle between normals angle exceeds radiansTolerance.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.