pointsToTriangulatedPolyface MethodStatic
Create a polyface from a triangulation of the points.
- The triangulation is computed as seen in the top view: z-coordinates are ignored.
- The highest z-coordinate is preserved for points that are separated by a vertical distance.
pointsToTriangulatedPolyface(points: Point3d[], options?: StrokeOptions): undefined | IndexedPolyface
@returns triangulated polyface or undefined
if triangulation was not possible.
Parameter | Type | Description |
---|---|---|
points | Point3d[] | an array of points. |
options | StrokeOptions | (optional) stroke options: * options.chordTol : xy-distance for equating points. For DTM points, 1-2mm may suffice. Default value isGeometry.smallMetricDistance .* options.needNormals : whether to assign 001 to all facets (rarely useful).* options.needParams : whether to assign all vertices uv-parameters equal to their xy-coordinates (rarely useful). |
Returns - undefined | IndexedPolyface
triangulated polyface or undefined
if triangulation was not possible.
Defined in
- polyface/PolyfaceBuilder.ts Line 1967
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.