findOrAddParamInLineString Method

Add a uv parameter to the polyface, taking u from ls.fractions and v from input. The implementation is free to either create a new param or return the index of a prior param with the same coordinates.

findOrAddParamInLineString(ls: LineString3d, index: number, v: number, priorIndexA?: number, priorIndexB?: number): undefined | number

@returns the uv parameter index in the polyface.

Parameter Type Description
ls LineString3d the linestring.
index number index of the point in the linestring.
v number the v parameter.
priorIndexA number (optional) an index of a prior param to check for possible duplicate value.
priorIndexB number (optional) another index of a prior param to check for possible duplicate value.

Returns - undefined | number

the uv parameter index in the polyface.

Defined in

Last Updated: 14 November, 2024