addTrianglesInUncheckedConvexPolygon Method
Add triangles from the first point of the linestring to the subsequent edges of the linestring.
- No checks are made for polygon convexity or edge collinearity, conditions which would ensure positive area triangles.
addTrianglesInUncheckedConvexPolygon(ls: LineString3d, toggle: boolean): void
Parameter | Type | Description |
---|---|---|
ls | LineString3d | linestring with point coordinates. |
toggle | boolean |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 313
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.