addTriangleFan Method
Add triangles from conePoint
to each far edge.
addTriangleFan(conePoint: Point3d, ls: LineString3d, toggle: boolean): void
Parameter | Type | Description |
---|---|---|
conePoint | Point3d | the common vertex of all triangles. |
ls | LineString3d | linestring with point coordinates. |
toggle | boolean | if true , wrap the triangle creation in toggleReversedFacetFlag. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 290
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.