addLinearSweepLineStringsXYZOnly Method
Add point data (no params, normals) for linestrings.
- This recurses through curve chains (loops and paths).
- LineStrings are swept.
- All other curve types are ignored.
addLinearSweepLineStringsXYZOnly(contour: AnyCurve, vector: Vector3d): void
Parameter | Type | Description |
---|---|---|
contour | AnyCurve | contour which contains only linestrings. |
vector | Vector3d | sweep vector. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1155
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.