addFacetFromIndexedVisitor Method
Add the subset of visitor data indexed by the indices.
- Ideally, the subset represents a sub-facet of the visited facet.
addFacetFromIndexedVisitor(visitor: PolyfaceVisitor, indices: number[]): boolean
@returns whether the data was added successfully. Encountering an invalid index returns false.
Parameter | Type | Description |
---|---|---|
visitor | PolyfaceVisitor | data for the currently visited facet. |
indices | number[] | local indices into the visitor data arrays. |
Returns - boolean
whether the data was added successfully. Encountering an invalid index returns false.
Defined in
- polyface/PolyfaceBuilder.ts Line 1595
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.