addCoordinateFacets Method

Add facets to the builder given arrays of coordinates for multiple facets.

  • pointArray[i] is an array of 3 or 4 points.
  • paramArray[i] is an array of matching number of params.
  • normalArray[i] is an array of matching number of normals.

addCoordinateFacets(pointArray: Point3d[][], paramArray?: Point2d[][], normalArray?: Vector3d[][], endFace: booleanfalse): void

Parameter Type Description
pointArray Point3d[][] array of arrays of point coordinates.
paramArray Point2d[][] (optional) array of arrays of uv parameters.
normalArray Vector3d[][] (optional) array of arrays of normals.
endFace boolean if true, call this.endFace after adding all the facets.

Returns - void

Defined in

Last Updated: 14 November, 2024